const regex = /\b(?!^)\d\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!^)\\d\\b', 'gm')
const str = `1. Задача, сделать что-то до 28.08. 2. Разобраться с замыканиями.`;
const subst = `\n$&`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);