# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/LINK\s*\(\s*(.+?)\s*,\s*([^\s]+)\s*\)/<a class="inlinelink" target="blank" href="$2">$1<\/a>/;t' <<< "LINK( string with multiple spaces, and commas , http://mydomain.com )"