package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`LINK\s*\(\s*(.+?)\s*,\s*([^\s]+)\s*\)`)
var str = []byte(`LINK( string with multiple spaces, and commas , http://mydomain.com )`)
var substitution = []byte("<a class="inlinelink" target="blank" href="$2">$1</a>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}