using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"LINK\s*\(\s*(.+?)\s*,\s*([^\s]+)\s*\)";
string substitution = @"<a class=""inlinelink"" target=""blank"" href=""$2"">$1</a>";
string input = @"LINK( string with multiple spaces, and commas , http://mydomain.com )";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}