# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"LINK\s*\(\s*(.+?)\s*,\s*([^\s]+)\s*\)"
test_str = "LINK( string with multiple spaces, and commas , http://mydomain.com )"
subst = "<a class=\"inlinelink\" target=\"blank\" href=\"$2\">$1</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.