$re = '/LINK\s*\(\s*(.+?)\s*,\s*([^\s]+)\s*\)/';
$str = 'LINK( string with multiple spaces, and commas , http://mydomain.com )';
$subst = "<a class=\"inlinelink\" target=\"blank\" href=\"$2\">$1</a>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;