use strict;
my $str = 'LINK( string with multiple spaces, and commas , http://mydomain.com )';
my $regex = qr/LINK\s*\(\s*(.+?)\s*,\s*([^\s]+)\s*\)/p;
my $subst = '<a class="inlinelink" target="blank" href="$2">$1</a>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";