import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "LINK\\s*\\(\\s*(.+?)\\s*,\\s*([^\\s]+)\\s*\\)";
final String string = "LINK( string with multiple spaces, and commas , http://mydomain.com )";
final String subst = "<a class=\"inlinelink\" target=\"blank\" href=\"$2\">$1</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}