#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<strong>\s*<a\s*href="([^"]+)".*?>([^<]+?)<\/a>"
Local $sString = " <a href="#" rel="nofollow">icon</a>" & @CRLF & _
" <strong>" & @CRLF & _
" <a href="LINK" rel="nofollow">Link 1</a>" & @CRLF & _
" </strong>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <a href="#" rel="nofollow">icon</a>" & @CRLF & _
" <strong>" & @CRLF & _
" <a href="LINK" rel="nofollow">Link 1</a>" & @CRLF & _
" </strong>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <a href="#" rel="nofollow">icon</a>" & @CRLF & _
" <strong>" & @CRLF & _
" <a href="LINK" rel="nofollow">Link 1</a>" & @CRLF & _
" </strong>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")