package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<strong>\s*<a\s*href="([^"]+)".*?>([^<]+?)<\/a>`)
var str = ` <a href="#" rel="nofollow">icon</a>
<strong>
<a href="LINK" rel="nofollow">Link 1</a>
</strong>
<a href="#" rel="nofollow">icon</a>
<strong>
<a href="LINK" rel="nofollow">Link 1</a>
</strong>
<a href="#" rel="nofollow">icon</a>
<strong>
<a href="LINK" rel="nofollow">Link 1</a>
</strong>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}