import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<strong>\\s*<a\\s*href=\"([^\"]+)\".*?>([^<]+?)<\\/a>";
final String string = " <a href=\"#\" rel=\"nofollow\">icon</a>\n"
+ " <strong>\n"
+ " <a href=\"LINK\" rel=\"nofollow\">Link 1</a>\n"
+ " </strong>\n\n\n\n\n"
+ " <a href=\"#\" rel=\"nofollow\">icon</a>\n"
+ " <strong>\n"
+ " <a href=\"LINK\" rel=\"nofollow\">Link 1</a>\n"
+ " </strong>\n\n\n\n\n"
+ " <a href=\"#\" rel=\"nofollow\">icon</a>\n"
+ " <strong>\n"
+ " <a href=\"LINK\" rel=\"nofollow\">Link 1</a>\n"
+ " </strong>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}