const regex = /<strong>\s*<a\s*href="([^"]+)".*?>([^<]+?)<\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<strong>\\s*<a\\s*href="([^"]+)".*?>([^<]+?)<\\\/a>', 'g')
const str = ` <a href="#" rel="nofollow">icon</a>
<strong>
<a href="LINK" rel="nofollow">Link 1</a>
</strong>
<a href="#" rel="nofollow">icon</a>
<strong>
<a href="LINK" rel="nofollow">Link 1</a>
</strong>
<a href="#" rel="nofollow">icon</a>
<strong>
<a href="LINK" rel="nofollow">Link 1</a>
</strong>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}