$re = '/<strong>\s*<a\s*href="([^"]+)".*?>([^<]+?)<\/a>/';
$str = ' <a href="#" rel="nofollow">icon</a>
<strong>
<a href="LINK" rel="nofollow">Link 1</a>
</strong>
<a href="#" rel="nofollow">icon</a>
<strong>
<a href="LINK" rel="nofollow">Link 1</a>
</strong>
<a href="#" rel="nofollow">icon</a>
<strong>
<a href="LINK" rel="nofollow">Link 1</a>
</strong>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);