// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<strong>\s*<a\s*href="([^"]+)".*?>([^<]+?)<\/a>"#).unwrap();
let string = " <a href=\"#\" rel=\"nofollow\">icon</a>
<strong>
<a href=\"LINK\" rel=\"nofollow\">Link 1</a>
</strong>
<a href=\"#\" rel=\"nofollow\">icon</a>
<strong>
<a href=\"LINK\" rel=\"nofollow\">Link 1</a>
</strong>
<a href=\"#\" rel=\"nofollow\">icon</a>
<strong>
<a href=\"LINK\" rel=\"nofollow\">Link 1</a>
</strong>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}