using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<strong>\s*<a\s*href=""([^""]+)"".*?>([^<]+?)<\/a>";
string input = @" <a href=""#"" rel=""nofollow"">icon</a>
<strong>
<a href=""LINK"" rel=""nofollow"">Link 1</a>
</strong>
<a href=""#"" rel=""nofollow"">icon</a>
<strong>
<a href=""LINK"" rel=""nofollow"">Link 1</a>
</strong>
<a href=""#"" rel=""nofollow"">icon</a>
<strong>
<a href=""LINK"" rel=""nofollow"">Link 1</a>
</strong>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}