# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:[a-z,]+\s+){0,2})here is\s+((?:[a-z,]+\s*){0,2})//gi;t' <<< "Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks."