import re
regex = re.compile(r"((?:[a-z,]+\s+){0,2})here is\s+((?:[a-z,]+\s*){0,2})", flags=re.IGNORECASE)
test_str = "Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks."
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)