re = /((?:[a-z,]+\s+){0,2})here is\s+((?:[a-z,]+\s*){0,2})/i
str = 'Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result