import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[a-z,]+\\s+){0,2})here is\\s+((?:[a-z,]+\\s*){0,2})";
final String string = "Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}