use strict;
my $str = 'Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks.';
my $regex = qr/((?:[a-z,]+\s+){0,2})here is\s+((?:[a-z,]+\s*){0,2})/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";