using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[a-z,]+\s+){0,2})here is\s+((?:[a-z,]+\s*){0,2})";
string substitution = @"";
string input = @"Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks.";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}