package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((?:[a-z,]+\s+){0,2})here is\s+((?:[a-z,]+\s*){0,2})`)
var str = `Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks. Parking here is horrible, this shop sucks.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}