using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+(?=[^""]+""<)";
string input = @"Bonjour,<br><br>Voici le numéro de téléphone de <strong>*NAME*</strong>"" : 0980653935 France""<br>
<br>Son adresse email est la suivante : heya1234@gmail.com<br>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}