$re = '`[0-9]+(?=[^"]+"<)`';
$str = 'Bonjour,<br><br>Voici le numéro de téléphone de <strong>*NAME*</strong>" : 0980653935 France"<br>
<br>Son adresse email est la suivante : heya1234@gmail.com<br>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);