using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\.(js|jsx|html|htm)";
string input = @"/foo/bar/baz.coffee
/usr/local/bin/stuff.js
boo.jsx
/foo/bar/baz/stuff.html
/foo/bar/baz-stuff.HTML
foo.htm";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}