import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\.(js|jsx|html|htm)";
final String string = "/foo/bar/baz.coffee\n"
+ "/usr/local/bin/stuff.js\n"
+ "boo.jsx\n"
+ "/foo/bar/baz/stuff.html\n"
+ "/foo/bar/baz-stuff.HTML\n"
+ "foo.htm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}