$re = '/.*\.(js|jsx|html|htm)/mi';
$str = '/foo/bar/baz.coffee
/usr/local/bin/stuff.js
boo.jsx
/foo/bar/baz/stuff.html
/foo/bar/baz-stuff.HTML
foo.htm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);