const regex = /.*\.(js|jsx|html|htm)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\.(js|jsx|html|htm)', 'gmi')
const str = `/foo/bar/baz.coffee
/usr/local/bin/stuff.js
boo.jsx
/foo/bar/baz/stuff.html
/foo/bar/baz-stuff.HTML
foo.htm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}