import re
regex = re.compile(r".*\.(js|jsx|html|htm)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("/foo/bar/baz.coffee\n"
"/usr/local/bin/stuff.js\n"
"boo.jsx\n"
"/foo/bar/baz/stuff.html\n"
"/foo/bar/baz-stuff.HTML\n"
"foo.htm")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")