re = /.*\.(js|jsx|html|htm)/mi
str = '/foo/bar/baz.coffee
/usr/local/bin/stuff.js
boo.jsx
/foo/bar/baz/stuff.html
/foo/bar/baz-stuff.HTML
foo.htm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end