package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi).*\.(js|jsx|html|htm)`)
var str = `/foo/bar/baz.coffee
/usr/local/bin/stuff.js
boo.jsx
/foo/bar/baz/stuff.html
/foo/bar/baz-stuff.HTML
foo.htm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}