#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^\p{Greek}{2,3}[0-9]{3,4}$"
Local $sString = "ΚΚΞ542" & @CRLF & _
"ΟΟΡ8888" & @CRLF & _
"ΠΠ8965" & @CRLF & _
"" & @CRLF & _
"INVALID STRINGS: " & @CRLF & _
"555555" & @CRLF & _
"K879" & @CRLF & _
"ΓΗΥΟ565"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")