package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\p{Greek}{2,3}[0-9]{3,4}$`)
var str = `ΚΚΞ542
ΟΟΡ8888
ΠΠ8965
INVALID STRINGS:
555555
K879
ΓΗΥΟ565`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}