const regex = /^\p{Greek}{2,3}[0-9]{3,4}$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\p{Greek}{2,3}[0-9]{3,4}$', 'gmu')
const str = `ΚΚΞ542
ΟΟΡ8888
ΠΠ8965
INVALID STRINGS:
555555
K879
ΓΗΥΟ565`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}