$re = '/^\p{Greek}{2,3}[0-9]{3,4}$/mu';
$str = 'ΚΚΞ542
ΟΟΡ8888
ΠΠ8965
INVALID STRINGS:
555555
K879
ΓΗΥΟ565';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);