import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\p{Greek}{2,3}[0-9]{3,4}$";
final String string = "ΚΚΞ542\n"
+ "ΟΟΡ8888\n"
+ "ΠΠ8965\n\n"
+ "INVALID STRINGS: \n"
+ "555555\n"
+ "K879\n"
+ "ΓΗΥΟ565";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}