using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\p{Greek}{2,3}[0-9]{3,4}$";
string input = @"ΚΚΞ542
ΟΟΡ8888
ΠΠ8965
INVALID STRINGS:
555555
K879
ΓΗΥΟ565";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}