use strict;
my $str = 'ΚΚΞ542
ΟΟΡ8888
ΠΠ8965
INVALID STRINGS:
555555
K879
ΓΗΥΟ565';
my $regex = qr/^\p{Greek}{2,3}[0-9]{3,4}$/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}