#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-+]?([0-9]*(\.[0-9]*)?[a-z]+)+$"
Local $sString = "30s" & @CRLF & _
"5m" & @CRLF & _
"5m30s" & @CRLF & _
"3m3m" & @CRLF & _
"3s3m" & @CRLF & _
"3m3m3m" & @CRLF & _
"0" & @CRLF & _
"m" & @CRLF & _
"s" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3h" & @CRLF & _
"3h0s" & @CRLF & _
"3h0m" & @CRLF & _
"a" & @CRLF & _
"123aa456aaa13aaa" & @CRLF & _
"45aa" & @CRLF & _
"54" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")