import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-+]?([0-9]*(\\.[0-9]*)?[a-z]+)+$";
final String string = "30s\n"
+ "5m\n"
+ "5m30s\n"
+ "3m3m\n"
+ "3s3m\n"
+ "3m3m3m\n"
+ "0\n"
+ "m\n"
+ "s\n"
+ "1\n"
+ "2\n"
+ "3h\n"
+ "3h0s\n"
+ "3h0m\n"
+ "a\n"
+ "123aa456aaa13aaa\n"
+ "45aa\n"
+ "54\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}