// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[-+]?([0-9]*(\.[0-9]*)?[a-z]+)+$").unwrap();
let string = "30s
5m
5m30s
3m3m
3s3m
3m3m3m
0
m
s
1
2
3h
3h0s
3h0m
a
123aa456aaa13aaa
45aa
54
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}