use strict;
my $str = '30s
5m
5m30s
3m3m
3s3m
3m3m3m
0
m
s
1
2
3h
3h0s
3h0m
a
123aa456aaa13aaa
45aa
54
';
my $regex = qr`^[-+]?([0-9]*(\.[0-9]*)?[a-z]+)+$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}