#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<([a-z]+)[^<>]*>[^<>]*(?R)*[^<>]*<\/\2>)|(<[a-z]+[^<>]*\/>)"
Local $sString = "<html>aaa<b></b><img src=”dfdfdfd” /> test </html>" & @CRLF & _
"<html fdfdfdskjf hsdkjfh skjdf hdskj>aaa<b></b><img src=”dfdfdfd” /> test </html>" & @CRLF & _
"<a><b /></a>" & @CRLF & _
"" & @CRLF & _
"<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>" & @CRLF & _
"<html>aaa<b><c/></b></html>" & @CRLF & _
"<html> aaa <b><c src=”dfdfdfd” /></b> aaa </html>" & @CRLF & _
"<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>" & @CRLF & _
"" & @CRLF & _
"<a><b /></a>" & @CRLF & _
"<b />" & @CRLF & _
"<a></a>" & @CRLF & _
"" & @CRLF & _
"invalid:" & @CRLF & _
"<a><b></a></b>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")