import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<([a-z]+)[^<>]*>[^<>]*(?R)*[^<>]*<\\/\\2>)|(<[a-z]+[^<>]*\\/>)";
final String string = "<html>aaa<b></b><img src=”dfdfdfd” /> test </html>\n"
+ "<html fdfdfdskjf hsdkjfh skjdf hdskj>aaa<b></b><img src=”dfdfdfd” /> test </html>\n"
+ "<a><b /></a>\n\n"
+ "<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>\n"
+ "<html>aaa<b><c/></b></html>\n"
+ "<html> aaa <b><c src=”dfdfdfd” /></b> aaa </html>\n"
+ "<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>\n\n"
+ "<a><b /></a>\n"
+ "<b />\n"
+ "<a></a>\n\n"
+ "invalid:\n"
+ "<a><b></a></b>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}