const regex = /(<([a-z]+)[^<>]*>[^<>]*(?R)*[^<>]*<\/\2>)|(<[a-z]+[^<>]*\/>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<([a-z]+)[^<>]*>[^<>]*(?R)*[^<>]*<\\\/\\2>)|(<[a-z]+[^<>]*\\\/>)', 'gm')
const str = `<html>aaa<b></b><img src=”dfdfdfd” /> test </html>
<html fdfdfdskjf hsdkjfh skjdf hdskj>aaa<b></b><img src=”dfdfdfd” /> test </html>
<a><b /></a>
<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>
<html>aaa<b><c/></b></html>
<html> aaa <b><c src=”dfdfdfd” /></b> aaa </html>
<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>
<a><b /></a>
<b />
<a></a>
invalid:
<a><b></a></b>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}