use strict;
my $str = '<html>aaa<b></b><img src=”dfdfdfd” /> test </html>
<html fdfdfdskjf hsdkjfh skjdf hdskj>aaa<b></b><img src=”dfdfdfd” /> test </html>
<a><b /></a>
<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>
<html>aaa<b><c/></b></html>
<html> aaa <b><c src=”dfdfdfd” /></b> aaa </html>
<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>
<a><b /></a>
<b />
<a></a>
invalid:
<a><b></a></b>';
my $regex = qr/(<([a-z]+)[^<>]*>[^<>]*(?R)*[^<>]*<\/\2>)|(<[a-z]+[^<>]*\/>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}