using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<([a-z]+)[^<>]*>[^<>]*(?R)*[^<>]*<\/\2>)|(<[a-z]+[^<>]*\/>)";
string input = @"<html>aaa<b></b><img src=”dfdfdfd” /> test </html>
<html fdfdfdskjf hsdkjfh skjdf hdskj>aaa<b></b><img src=”dfdfdfd” /> test </html>
<a><b /></a>
<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>
<html>aaa<b><c/></b></html>
<html> aaa <b><c src=”dfdfdfd” /></b> aaa </html>
<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>
<a><b /></a>
<b />
<a></a>
invalid:
<a><b></a></b>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}