$re = '/(<([a-z]+)[^<>]*>[^<>]*(?R)*[^<>]*<\/\2>)|(<[a-z]+[^<>]*\/>)/m';
$str = '<html>aaa<b></b><img src=”dfdfdfd” /> test </html>
<html fdfdfdskjf hsdkjfh skjdf hdskj>aaa<b></b><img src=”dfdfdfd” /> test </html>
<a><b /></a>
<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>
<html>aaa<b><c/></b></html>
<html> aaa <b><c src=”dfdfdfd” /></b> aaa </html>
<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>
<a><b /></a>
<b />
<a></a>
invalid:
<a><b></a></b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);