import Foundation
let pattern = #"(<([a-z]+)[^<>]*>[^<>]*(?R)*[^<>]*<\/\2>)|(<[a-z]+[^<>]*\/>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<html>aaa<b></b><img src=”dfdfdfd” /> test </html>
<html fdfdfdskjf hsdkjfh skjdf hdskj>aaa<b></b><img src=”dfdfdfd” /> test </html>
<a><b /></a>
<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>
<html>aaa<b><c/></b></html>
<html> aaa <b><c src=”dfdfdfd” /></b> aaa </html>
<html>aaa<b></b><img src=”dfdfdfd”> df </img></html>
<a><b /></a>
<b />
<a></a>
invalid:
<a><b></a></b>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)