package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\D+$`)
var str = `"a"
abc dsa
fsdfsd
qěč+ěčřčýřžýř
10
a b- g+ * asfd
100
abc 10 dsa
15
asdfas
2a
-8
a5
something ... and so one`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}